Предыдущий пост Поделиться Следующий пост
Из коробки не работает
March 2015
alex_mashin
Обновил одну систему с Ubuntu 16.10 до 17.04.

В этот раз апгрейд был особо кровав (это в последние годы тенденция). Сразу же сломались nginx, HHVM и Samba.

nginx было проще всего: достаточно было удалить Apache, который услужливо установила программа обновления, и который, конечно, захватил 80-ый порт.

HHVM всё было хуже: под 17.04 не просто нет собранного пакета; последние версии под 17.04 и не установятся, так как хотят пакеты, которых там нет. Можно поставить старую версию 3.12 из репозитория Ubuntu, а потом ставить недостающие пакеты при сборке расширений, и вспоминать, как обойти баг при подключении к базе данных.

К шаре Samba не подключишься, пока не узнаешь, что протокол аутентификации NTLM больше по умолчанию не поддерживается (с версии Samba 4.5); используйте ntlmssp. Что характерно, ни малейшего намёка на это (и вообще, на попытку логина) ни в каких логах нет.

Метки:

  • 1
> Обновил одну систему с Ubuntu 16.10 до 17.04

Это зря. Ubuntu настоятельно рекомендую использовать как на десктопах так и на серверах только LTS (14.04, 16.04, 18.04 etc). А промежуточные стоит использовать разве что разработчикам или кому абсолютно неважна стабильность.

В LTS релизах за последние лет 8 лично мной не было замечено ни разу подобных проблем. Ставил на несколько десятков рабочих столов разным людям и организациям (на сервер, правда, всего один раз убунту ставил, проработала 5 лет в принципе стабильно 10.04, но при обновлении железа решил все таки дебиан установить).

В 2008ом когда только начинал щупать ubuntu - тоже сталкивался с проблемами при обновлении релизов, но как перешёл на LTS - уже забыл про всё это.

  • 1
?

Log in

No account? Create an account